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Preface 

This document is an evolving document that presents various features of the Gedae Flow Graph 

Editor. While not complete at this time, we will add descriptions of new features as they are 

developed and also incrementally add descriptions of all the existing editor features. 



Parameter Table  

A Parameter Table displays all the parameters associated with the flow graph. If opened on a subgraph, 

then only the parameters on the subgraph are shown. Before the table can be opened, the flow graph 

must be attached to its functional definition. If the graph is not already attached, then Gedae attaches 

the graph.  

 

Figure 1 Parameter Table 

The values of each parameter are listed under the Value column.  A parameter is settable if it is not a 

constant and is not derived from any other parameters.  A runtime-settable parameter is settable and its 

value does not affect data flow or the schedule.  For example, an array size might be settable, but not 

runtime settable, if it determines the amount of statically allocated memory.  

Any currently undefined parameter is indicated by the word unset. 



To set the value of any parameter, type the value into the Value column of the table in the row 

corresponding to the data element.  If the parameter is a string, enclose the characters in double-

quotes.  If the parameter is listed as ..., the value cannot be displayed in the table. 

Parameters can be set by value or by reference.  To set by value, simply enter the number or string into 

the Value column as described above.  To set by reference, enter the “dot string” corresponding to the 

parameter you wish to reference.  A dot string lists the box hierarchy describing the location of the data 

element, separated by periods, followed by a “>” symbol and the name of the data element.  For 

example, if subgraph A has a subgraph B which has a local C, the dot string A.B>C specifies the local and 

can be used in the Parameter Table to set any other parameter of the same type.  The only limitation in 

using set by reference is that each parameter must be typed. 

Any parameter that can be set by value can also be set by reference, however parameters of type 

pointer and trigger parameters can only be set by reference.   A trigger is an input parameter to a 

Trigger primitive where the input is declared as a trigger. 

The parameter file for a subgraph can also be loaded through the Parameter Table.  Type the name of 

the parameter file into the Value column, and Gedae will open the parameter file for that subgraph.  

When saving and restoring a parameter file, this hierarchy is also saved and restored.  The parameter 

table is the only place where parameter hierarchy can be set and maintained; if a parameter is set in the 

flow graph editor, it will be stored in the toplevel graph’s parameter file. 

The Parameter  Table  File Menu  

Close    Close the Parameters table.  

Print   Open the Print Settings Dialog. 

Open Synonyms  Open a synonym file. 

The Parameter Table Edit Menu  

Find    Find text in the Name column. 

Find Next   Find text again, starting from the current location in the table. 

Copy Name   Copy the parameter name of the selected parameter. 

This option is useful in setting parameters by reference as the name 

placed in the clipboard can be simply pasted in this Parameter Table or 

another one to set by reference. 

Cut Copy the selected text to the clipboard and delete it from the current 

text entry area. 

Copy Copy the selected text to the clipboard. 

Paste Paste the text from the clipboard to the current text entry area. 



The Parameter  Table  View Menu   

The scope of these selections is the entire table.It is not necessasry to select a  row,  and any 

highlighting or selection of rows is ignored by the program. 

Expand  Display all rows one level from the top. 

                                                 If there are any hidden boxes at the top level, this brings them back into 

view. If there are hidden boxes in any hierarchical box, these boxes will 

remain hidden. To get all the boxes back into view, use View­Show All 

Boxes. 

Show All Boxes  Display every box in the flow graph. 

  If there are any collapsed hierarchical boxes at any level, this expands 

them showing every sub-box as an entry in the table.  

If there are any hidden boxes at any level, this displays them as entries 

in the table  

If the table is completely expanded showing all the boxes and I/O, this 

option will reduce the table to having just the boxes as table entries. 

That is, it will hide the data entries. 

Show All Data and Boxes  Display every box, input queue, and output queue in the flow graph. 

Sort By Dependency  Sort parameters based on dependency. 

Sort Alphabetically  Sort parameters in alphabetic order. 

Runtime Settable  Display parameters that can be set at runtime. 

Settable        Display settable parameters that must be set in order for the graph to 

run. 

Settable With Triggers Displays all settable parameters, including triggers that can be set by 

reference. 

Unset  Display only unset parameters that must be set in order for the graph to 

run. 

Unset With Triggers  Display only unset parameters, including triggers that can be set by 

reference. 

Non Constant  Display all non-constant parameters.  

All Display all parameters. 



The Parameter  Table  Options Menu  

These options manipulate highlighted rows. At least one row must be selected or these selections have 

no effect.  

Multiple rows may be selected by holding down <shift> while clicking the left mouse button. 

Expand  Displays all sub-boxes and parameters for the selected box.  When a box 

is selected and expanded, this option shows all the boxes and 

parameters one level below the selected level.  Boxes and parameters 

more than one level below the selected level will be displayed only if 

they were displayed prior to collapsing the selected box.  

Expand, also,  by double clicking on the box name. 

 

Collapse  Collapses the table so that all sub-boxes and parameters of the selected 

entry are hidden.  If the same selected entry is subsequently expanded, 

then the table will appear exactly as it did before it was collapsed, 

except that items one level below the selected box will no longer be 

hidden if they were hidden before the collapse.  Any items more than 

one level below the selected item will remain expanded, collapsed, or 

hidden according to their state before the collapse.  

Collapse  also  by double-clicking on the box name. 

Hide  Hide the selected box or parameter from view. 

 Hide also can be accomplished by holding down <shift> and double-

clicking the left mouse button while the cursor is on the box name. 

Show All Boxes  Display all the boxes in the hierarchy of the selected rows.  Parameters 

are not shown. 

If there are any collapsed hierarchical boxes at any level below the 

selected box, this option expands them while showing every sub-box as 

an entry in the table.   

If there are any hidden boxes at any level below the selected item, this 

option displays them as entries in the table.  

                                                 If any parameters are displayed, they will be hidden by this option.   

After selecting this option all boxes and sub-boxes will be displayed, but 

no parameters will be displayed.  



Show All Data and Boxes     Display all the boxes and parameters in the hierarchy of the selected 

rows.  

 If there are any collapsed hierarchical boxes or parameters at any level 

below the selected box, this option expands them showing every sub-

box as an entry in the table. 

   If there are any hidden boxes or parameters at any level below the 

selected item, this option displays them as entries in the table. 

Edit Data If a primitive input is selected, then bring up the Edit Data Dialog. 

Edit data can also be done by double-clicking on the parameter name. 

Choose File If a subgraph is selected, then bring up a choose dialog to select 

parameter file for that subgraph. 

Open Table If a subgraph is selected, then open the Parameter Table for that 

subgraph. 

Set Value Set the value for the selected parameter. 

 The value can also be set by typing directly into the Value column of the 

table. 

 



Add Data Dialog  

The Add Data Dialog is used to add input, output, local, and range variables and queue initializations. 

Only one Add Data Dialog can be open at a time.  The focus of the Add Data Dialog is the last window 

from which the Edit->Add Data option was selected and is indicated by a highlighted canvas.  If you wish 

to add data objects to another canvas, then select the Edit->Add Data option from the canvas menu. The 

canvas will change color to indicate the change in focus.   

The first time the Add Data Dialog is displayed all fields will be unset. Subsequently this dialog will 

display the last data entered. 

When the Add Data Dialog is closed, the canvas that has the focus reverts to its normal color. 

 

Figure 1 Add Data Dialog 

The Add Data Dialog has four sections: Data Declaration Components, Text Entry Panels, Data 

Declaration Panel, and Control Buttons. 

Data Declaration Components  

There are three option buttons in the Data Declaration Components section. The left button selects the 

form of the data. The available options are: 

input Input to the hierarchical box. 

output Output from the hierarchical box. 

local Local variable. 



range Range of values from 0 to value. 

 

The middle button selects the variability of the data.  The available options are: 

var  Variable 

const Constant value 

stream Stream 

 

The right button selects the data type. The available options are: 

untyped No specified data type 

int  Integer 

float Floating point number 

double Double precision floating point number 

complex Complex number  

dcomplex Double precision complex number 

string Any C character string 

pointer Pointer such as the C-type void * 

 
_____________________________________________________________________________________________________________________ 

Note - A const value must be used for graph instantiation parameters.  Streams cannot be set to a value, 

and the stream modifier is not required or enforced by Gedae.  Data of type untyped and pointer also 

cannot be set to a value; they can only obtain a value through arcs on the canvas. 

Text Entry Panels  

The Text Entry Panels include the following: 

¶ Families Family range index 

¶ Name Unique name of the data description  

_____________________________________________________________________________________ 

Note- Use a name beginning with the string “unnamed” to suppress a const data declaration from the 

graph and to only show the value. 

¶ Dim Range index that spans the number of dimensions 

¶ Value The value of the variable, or an equation which evaluates to the value of the 

variable. For long equations, an ellipsis Mark (…) may be entered and the Value 
button selected, then the equation may be typed in the resulting Edit Value 
Dialog. 

 
The Value Panel is desensitized if not required. 

The following is a table of data combinations that are legal: 



Data Declaration 

Component 

Type Families Names Dim Value 

input var * X X X  

const * X X X  

stream * X X X  

output var  X X   

const  X X   

stream  X X   

local var * X X X X 

const * X X X X 

stream * X X X X 

range   X X  X 

Table 1 Legal Combinations of Data Characteristics(* Values for type field are: untyped, int, float, 

double, complex,dcomplex, string, pointer) 

_____________________________________________________________________________________ 

Note - After entering data in the Text Entry Panels, a <Return> must be pressed to enter that data in the 

Data Declaration panel. If <Return> is not pressed, then the data entry has no effect. 

Data Declaration Panel  

The data in the Data Declaration Panel is placed on the canvas when either the OK button is clicked or 

<Return> is pressed.  The data declaration may be typed directly into this panel instead of each 

individual selection above. When OK is clicked or <Return> is pressed, the information is back-filled into 

the appropriate panels above. 

If an invalid entry is made, then the declaration is displayed in red, and GEDAE displays the following 

error message:  

Could not parse data declaration: 

Data that was entered. 

Control Buttons  
The functions of the control buttons are: 



¶ OK Put the data element listed in the Data Declaration panel onto the canvas. 

¶ Clear  Clear all the information in the panels the dialog. 

¶ Cancel  Close the dialog without any further action. 



Restore and Manage Dialog  

The Restore and Manage Dialog is used to manage an archive of the flow graph previously saved using 

the Archive Dialog.  Gedae uses the Tape ARchive format (TAR) for saving and restoring archives of 

applications.  After selecting File->Restore and Manage…, the user is prompted to select the archive to 

manage.  The file dialog is initially set to the directory FGlibraries/archives/<path_to_toplevel_graph>/, 

however archives can be loaded from any directory. 

After selecting an archive to manage, the Restore and Manage dialog presents all the files stored in the 

archive.  The files are grouped into five sets: Boxes, Parameters, Groups, Constants, and Others.  The 

Boxes include all primitives and flow graph files, the Parameters include parameter files for the toplevel 

flow graph and all subgraphs, the Groups include group settings files for the toplevel flow graph and all 

subgraphs, and the Others include any other files optionally added to the archive.   

 

Figure 2 Restore and Manage Dialog 

For each file in the archive, the user can specify the location to restore the file.  This new location can be 
entered by typing directly into the New Location column of the Dialog, or by selecting a Name from the 
first column and going to the menu option Options->Set New Location…  The rightmost column, Exists, 
informs the user a file exists in the path currently specified by New Location.  For example, if an archive 
is restored and some files are already in the Gedae library and some files are not, the user can view 
which are not already present and select to only restore those files. 



The Options menu, show below, also contains options for restoring the archive or portions of the 
archive, adding files to the archive, and finding the difference between files in the archive and the 
current files. 

 

Figure 3 Restore and Manage Dialogôs Options menu 

The three options for restoration are Restore, Restore Renamed, and Restore All.  The Restore option 
restores only the selected files, and the Restore All option restores all the files in the archive.  The 
Restore Renamed option restores all the files in the archive where the user has specified a new location 
for the file. 
 
The Add… option brings up a file dialog that allows the user to specify a file to add to the archive. 
 
The View Diff Results and View Diff Type options provide information on the difference between the file 
in the archive and the current file.  The difference information is found when the Restore and Manage 
Dialog is launched and is not updated if the locations of entries in the table are changed.  When the 
dialog is launched, differences are specified in the table by the color code shown in the table below.  The 
two options for viewing the difference are only enabled if a difference has been found.  The View Diff 
Results option shows the difference using an external file difference program, such as “diff” (the 
program used can be customized via the DIFF environment variable).  The View Diff Type option 
translates the color coding into the information shown in the Table below. 
 
Similar to other Gedae dialogs, the Expand, Collapse, Hide, and Show All Boxes options can be used to 
alter the appearance of the table by controlling which items are displayed. 
 

Color Type of Difference 

Red Dataflow different – This change may cause a rescheduling of the graph. 

Orange Functionally different – This change represents a change in the algorithm, but may not 
require rescheduling. 

Yellow Data different – The algorithm and scheduling have not changed, but the values of some 
parameters have changed. 

Blue Cosmetically different – This change does not affect the behavior or results of the graph. 

Violet Pervasively cosmetically different – This cosmetic difference may still require a rescheduling  



of the graph, e.g., a data element’s name has changed. 

Table 2 Color coding used by the flow graph difference utilities 

To simplify the changing of restoration locations, there are several options in the menus to change many 
names at once.  These options are found in the Edit menu shown below.  The Replace All… option allows 
the user to do a find and replace on all the locations in the current archive.  The Insert Before… option 
allows the user to enter text that will be inserted before the locations of all selected items.  These 
insertion options are useful for adding a directory path level above the files, such as restoring the flow 
graph to a new parent directory to avoid any potential conflicts.  The Reset All New Location Entries can 
be used to revert back to the original settings. 
 

 

Figure 4 Restore and Manage Dialogôs Edit menu 

Similar to other Gedae dialogs, the Find… and Find Next options can be used to find text in the Dialog, 
and the Cut, Copy, and Paste options can be used to cut, copy, and paste between the editable fields (in 
this case, only the New Location field). 
 
To preserve the behavior of the graph there are some limitations on how the names can be altered.  
These limitations are: 

¶ The names of Boxes cannot be altered, only the directories they are stored under. 

¶ If the path of the toplevel flow graph changes, the paths of Parameters, Groups, and Constants will 
be changed to match the flow graph’s new path. 

 

 

 

 

 

 


